Installation Citrix Workspace sous Ubuntu 18

140 x served & 73 x viewed

La première étape est le téléchargement du soft sur : https://www.citrix.com/downloads/workspace-app/linux/workspace-app-for-linux-latest.html .

Le lien direct : https://downloads.citrix.com/16914/icaclient_19.12.0.19_amd64.deb

$ sudo dpkg -i icaclient_19.12.0.19_amd64.deb 

Sélection du paquet icaclient précédemment désélectionné.
(Lecture de la base de données... 370627 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de icaclient_19.12.0.19_amd64.deb ...
Dépaquetage de icaclient (19.12.0.19) ...
Paramétrage de icaclient (19.12.0.19) ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.13.3-11ubuntu1.1) ...
Traitement des actions différées (« triggers ») pour bamfdaemon (0.5.3+18.04.20180207.2-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.23-1ubuntu3.18.04.2) ...
Traitement des actions différées (« triggers ») pour mime-support (3.60ubuntu1) ...

$ sudo cp /usr/share/ca-certificates/mozilla/*.crt /opt/Citrix/ICAClient/keystore/cacerts/

Ensuite il faut faire la congiguration via :

$ /opt/Citrix/ICAClient/util/configmgr

Ensuite je fais un petit check :

$ /opt/Citrix/ICAClient/util/hdxcheck.sh
=========================================================
= Pre-requisite check for the Citrix Workspace for Linux =
=                 Version 1.4 (June 2015)               =
=========================================================

-------------------------------
-- Client Information...      -
-------------------------------
Client version:
19.12.0.19
Install location:
/opt/Citrix/ICAClient

-------------------------------
-- Checking Kernel Version... -
-------------------------------
Success, a compatible kernel version(5.3.0) has been found.
--------------------------------------------
-- Checking Audio support dependencies..   -
--------------------------------------------

------------------------------------------------------------------
-- Checking that ALSA Support is installed...
------------------------------------------------------------------
Success! - ALSA is installed!

-----------------------------------------------------
-- Checking for SPEEX and VORBIS Audio Support...
-----------------------------------------------------
Success! All SPEEX and VORBIS dependencies found!

--------------------------------------------
-- Checking HDX MediaStream dependencies.. -
--------------------------------------------

/opt/Citrix/ICAClient/util/gst_play0.10: error while loading shared libraries: libgstinterfaces-0.10.so.0: cannot open shared object file: No such file or directory
The minimum required version of GStreamer is 0.10.25
You are using version  of GStreamer
Warning! - A compatible version of GStreamer could not be located!

The minimum required version of GStreamer 1.0 is 1.2.4
You are using version 1.14.5 of GStreamer 1.0
Success! - A compatible version of GStreamer 1.0 is installed!

Your version of libcurl is: 7.58.0
Sucesss! Correct libCurl version found

------------------------------------------------------------------
-- Checking GStreamer webcam Support ...
------------------------------------------------------------------
Warning! - some dependencies required for webcam support are missing.
	libgstinterfaces-0.10.so.0 => not found
	libgstapp-0.10.so.0 => not found
	libgstbase-0.10.so.0 => not found
	libgstreamer-0.10.so.0 => not found
	libgstreamer-0.10.so.0 => not found
	libgstapp-0.10.so.0 => not found
	libgstpbutils-0.10.so.0 => not found

------------------------------------------------------------------
-- Checking GStreamer 1.0 webcam Support ...
------------------------------------------------------------------
Success! - Gstreamer 1.0 webcam dependencies installed!

--------------------------------------
-- Checking for printing support ... -
--------------------------------------
Success! - Printing system found

The following printers are installed in your system: 
lpstat: Aucune destination ajoutée.

-----------------------------------
-- Checking Display Server Support ... -
-----------------------------------
Success! - Your display server is X11, compatible with your Desktop and App sessions

-----------------------------------
-- Checking Webkit Support ... -
-----------------------------------
Success! - libwebkit2gtk-4.0.so.37 is installed. Selfservice support is present. Recommended version for libwebkit2gtk is (>=2.16.6),

-----------------------------------
-- Checking if libpng is present ... -
-----------------------------------
Success! - libpng is present.,

-----------------------------------
-- Checking SaaS App Support ... -
-----------------------------------
Success! All SaaS App Support dependencies found!

-----------------------------------
-- Checking Smartcard Support ... -
-----------------------------------
Success! - Libpcsclite.so installed. Smartcard support enabled.
libpcsclite was found on your system but it's version could not be determined.
Make sure you have version 1.5.6 or later

------------------------------------
--- Checking other dependencies .. -
------------------------------------

-----------------------------------------------------
-- Checking Client Library dependencies...
-----------------------------------------------------
Success! All client dependencies found!

-----------------------------------------------------
-- Checking OS Library dependencies...
-----------------------------------------------------
Success! All OS dependencies found!

-----------------------------
-- Checking For USB Support..
-----------------------------

--------------------------------------------------------------
-- Checking that a compatible version of udev is installed...
--------------------------------------------------------------
A compatible version of udev is installed!

---------------------------------------------------------------
-- Checking that a compatible version of glibc is installed...
---------------------------------------------------------------
The minimum required version is 2.7
You are using version 2.27 of glibc
A compatible version of glibc is installed!

----------------------------------------------------------------
-- Checking that a compatible version of libcap is installed...
----------------------------------------------------------------
A compatible version of libcap is installed!
Success! All USB dependencies found!

-----------------------------------
- Checking X-window dependencies  -
-----------------------------------
-----------------------------------------------------------------
-- Checking that your system supports the minimum color depth...
-----------------------------------------------------------------
The minimum required color depth is 8 bit
Your system supports up to 32 bit
Success! - A compatible color depth is available!

------------------------------------------------------------
-- Checking that your XServer supports Seamless Windows...
------------------------------------------------------------
Success! - Seamless windows are supported!
-------------------------------------------------------
-- Checking that your XServer supports Multi-Monitor...
-------------------------------------------------------
Success! - Multi-monitor is supported!
Found the following Monitors:
  head #0: 1920x1080 @ 0,0


-----------------------------------
- Checking Instrumentation support  -
-----------------------------------
----------------------------------------------------------------
-- Checking that a compatible version of libjson is installed on your system...
----------------------------------------------------------------
A compatible version of libjson-c is installed! CAS and CEIP will be supported

Success! Instrumentation support will be provided!

===================================================================
= Pre-requisite check for the Citrix Workspace for Linux Completed =
===================================================================
Logfile: /tmp/logfile.txt

Ensuite il suffit de lancer l’application : Citrix Workspace :

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Time limit is exhausted. Please reload CAPTCHA.