Ubuntu 18 : Installation d’un client NextCloud avec Flatpak

44 x served & 18 x viewed

Les commandes pour l’installation :

$ sudo apt install flatpak
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés : 
  libostree-1-1 xdg-desktop-portal xdg-desktop-portal-gtk
Les NOUVEAUX paquets suivants seront installés :
  flatpak libostree-1-1 xdg-desktop-portal xdg-desktop-portal-gtk
0 mis à jour, 4 nouvellement installés, 0 à enlever et 13 non mis à jour.
Il est nécessaire de prendre 1 313 ko dans les archives.
Après cette opération, 5 898 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] O
...
$ flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

$ flatpak install flathub org.nextcloud.Nextcloud
Required runtime for org.nextcloud.Nextcloud/x86_64/stable (runtime/org.kde.Platform/x86_64/5.12) found in remote flathub
Do you want to install it? [y/n]: y
Installing in system:
org.kde.Platform/x86_64/5.12                       flathub 8337138165ca
org.freedesktop.Platform.VAAPI.Intel/x86_64/18.08  flathub 227f12933709
org.freedesktop.Platform.html5-codecs/x86_64/18.08 flathub b7006caaf6a7
org.kde.Platform.Locale/x86_64/5.12                flathub b76e501f9811
org.nextcloud.Nextcloud/x86_64/stable              flathub 4755c241adb7
  permissions: ipc, network, wayland, x11, dri
  file access: host, xdg-config/kdeglobals:ro, xdg-run/Nextcloud:create, xdg-run/dconf, ~/.config/dconf:ro
  dbus access: com.canonical.AppMenu.Registrar, org.freedesktop.Notifications, org.freedesktop.secrets, org.kde.StatusNotifierWatcher
org.nextcloud.Nextcloud.Locale/x86_64/stable       flathub f098e4785813
Is this ok [y/n]: y
Installing: org.kde.Platform/x86_64/5.12 from flathub
[####################] 1415 metadata, 27766 content objects fetched; 404772 KiB transferred in 128 seconds
Now at 8337138165ca.
Installing: org.freedesktop.Platform.VAAPI.Intel/x86_64/18.08 from flathub
[####################] 4 metadata, 2 content objects fetched; 1783 KiB transferred in 0 seconds
Now at 227f12933709.
Installing: org.freedesktop.Platform.html5-codecs/x86_64/18.08 from flathub
[####################] 22 metadata, 127 content objects fetched; 3111 KiB transferred in 1 seconds
Now at b7006caaf6a7.
Installing: org.kde.Platform.Locale/x86_64/5.12 from flathub
[####################] 33 metadata, 196 content objects fetched; 5085 KiB transferred in 1 seconds
Now at b76e501f9811.
Installing: org.nextcloud.Nextcloud/x86_64/stable from flathub
[####################] 78 metadata, 221 content objects fetched; 4049 KiB transferred in 2 seconds
Now at 4755c241adb7.
Installing: org.nextcloud.Nextcloud.Locale/x86_64/stable from flathub
[####################] 7 metadata, 2 content objects fetched; 5 KiB transferred in 0 seconds
Now at f098e4785813.

$ flatpak run org.nextcloud.Nextcloud
Gtk-Message: 14:04:44.389: Failed to load module "canberra-gtk-module"
Gtk-Message: 14:04:44.389: Failed to load module "canberra-gtk-module"

On a donc la fenetre suivante qui s’ouvre, et il suffit de faire la configuration :

J’ai pas trop compris l’erreur non bloquante: « canberra-gtk-module », car j’ai pas l’impression de manquer de librairie :

$ sudo apt-get install libcanberra-gtk-module
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libcanberra-gtk-module est déjà la version la plus récente (0.30-5ubuntu1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gconf-service gconf-service-backend gconf2 gconf2-common libappindicator1 libdbusmenu-gtk4 libfwup1 libgconf-2-4 libindicator7
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
$ sudo apt install libcanberra-gtk-module libcanberra-gtk3-module
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libcanberra-gtk3-module est déjà la version la plus récente (0.30-5ubuntu1).
libcanberra-gtk-module est déjà la version la plus récente (0.30-5ubuntu1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gconf-service gconf-service-backend gconf2 gconf2-common libappindicator1 libdbusmenu-gtk4 libfwup1 libgconf-2-4 libindicator7
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
$ sudo apt-get install libcanberra-gtk-module:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
libcanberra-gtk-module:i386 est déjà la version la plus récente (0.30-5ubuntu1).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  gconf-service gconf-service-backend gconf2 gconf2-common libappindicator1 libdbusmenu-gtk4 libfwup1 libgconf-2-4 libindicator7
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Time limit is exhausted. Please reload CAPTCHA.